Change database settings so Omeka indexes 3 letter words and less


I’m working on a project hosted on Reclaim and running Omeka. We’re running into an issue; many of our items are tagged “HIV” but they aren’t showing up in searches. This is super important, as HIV is one of the main categories on our site and comprises about half our items. We know people will search “HIV” and need the results to return.

From some online research, it seems like it’s because the database isn’t indexing entries with 3 letters or less.

Does anyone know if this is a setting that can be changed on my end? I’m using the default database and settings set up through Installatron. I’m familiar with MySQL and phpMyAdmin and am willing to change settings there, if need be.

I’d really appreciate any help with this, and am happy to provide more information if needed.



That does appear to be a mysql setting and one you can modify.

Yeah if this is for one of our servers you’ll need to submit a ticket. We’ve done it by request before but it’s not a default on our servers and it is indeed a setting that has to be done to the MySQL config on the server.

Thank you very much! I’ll submit a ticket.