CSV Import Error - configured PHP path does not point to a PHP-CLI binary?

Good Morning! I have installed Omeka Classic and am trying to import files using the CSV Plug-in. Two questions (below) Many thanks!!!

  1. Where in the “File manager” do I put the files for a batch CSV upload? Can I do batch uploads with files stored in my Reclaim server?

  2. When I try to upload a CSV in Omeka (both with and without a file column), I get the following error message:

RuntimeException: The configured PHP path (/usr/local/bin/php) does not point to a PHP-CLI binary. in /home/cbswimar/public_html/application/libraries/Omeka/Job/Process/Dispatcher.php:124 Stack trace: #0 /home/cbswimar/public_html/application/libraries/Omeka/Job/Process/Dispatcher.php(93): Omeka_Job_Process_Dispatcher::_checkCliPath(‘/usr/local/bin/…’) #1 /home/cbswimar/public_html/application/libraries/Omeka/Job/Process/Dispatcher.php(28): Omeka_Job_Process_Dispatcher::getPHPCliPath() #2 /home/cbswimar/public_html/application/libraries/Omeka/Job/Dispatcher/Adapter/BackgroundProcess.php(31): Omeka_Job_Process_Dispatcher::startProcess(‘Omeka_Job_Proce…’, Object(User), Array) #3 /home/cbswimar/public_html/application/libraries/Omeka/Job/Dispatcher/Default.php(151): Omeka_Job_Dispatcher_Adapter_BackgroundProcess->send(‘{“className”:"C…’, Array) #4 /home/cbswimar/public_html/plugins/CsvImport/controllers/IndexController.php(384): Omeka_Job_Dispatcher_Default->sendLongRunning(‘CsvImport_Impor…’, Array) #5 /home/cbswimar/public_html/plugins/CsvImport/controllers/IndexController.php(135): CsvImport_IndexController->_dispatchImportTask(Object(CsvImport_Import), ‘start’) #6 /home/cbswimar/public_html/application/libraries/Zend/Controller/Action.php(516): CsvImport_IndexController->mapColumnsAction() #7 /home/cbswimar/public_html/application/libraries/Zend/Controller/Dispatcher/Standard.php(308): Zend_Controller_Action->dispatch(‘mapColumnsActio…’) #8 /home/cbswimar/public_html/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http)) #9 /home/cbswimar/public_html/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(105): Zend_Controller_Front->dispatch() #10 /home/cbswimar/public_html/application/libraries/Zend/Application.php(384): Zend_Application_Bootstrap_Bootstrap->run() #11 /home/cbswimar/public_html/application/libraries/Omeka/Application.php(73): Zend_Application->run() #12 /home/cbswimar/public_html/admin/index.php(28): Omeka_Application->run() #13 {main}

1 Like

Hi Megan,

I replied to the ticket you submitted as well, but appreciate you make this a community post given this could be useful to many other folks. I tried change the PHP config file in config.ini to background.php.path = “/usr/bin/php-cli” given it was already pointing to background.php.path = “/usr/local/bin/php”

I am not sure this will work, but it is a first level test before I escalate to folks smarter than me, the other thing is you should be able to upload the CSV file directly through browser, no need to upload via File Manager, but let me know if you are seeing instructions in Omeka suggesting otherwise. Once we figure this out I’ll be sure to follow-up here, so think of this as an interim response until I find out of my attempt at a quick fix works, otherwise it will be escalated and responded to later.


Hi Jim, Thanks for your quick response! I just tried again - using the Omeka Browser. Same error message.

I do have two parts to this question - one is uploading the csv and resulting error message,
and the other is where are the jpg files supposed to ‘live’ - how are they pulled into the database and connected with the csv? Can they ‘live’ in my Reclaim files?
Thank you so much for your help!!

Hi Jim, Sorry to bother you again - any luck with this?

This has been escalated given it looks to be a server specific issue, I’ll follow-up later today once I have more specifics

1 Like

Hi hi Reclaim Hosting! Any luck? Is there a different Plugin I should use? I tried the Dropbox plug in, but I would really like the CSV metadata import capacity.
Best wishes… m

Hi Megan,

We responded in the support ticket you opened several days ago, wondering if you happened to see that? At this point it’s probably better to follow up there given this appears to be an issue specific to your account. Any additional logs you can provide will help there. Also keep in mind you may have better support for the Omeka software and the questions you have from the Omeka forums at https://forum.omeka.org/.

Oh lovely!! Thank you. Sorry, I did miss that.