CSV Import into Omeka Classic not working

I’ve been trying to import a CSV file into my db on reclaimhosting, but it just keeps saying “Import error” with zero files uploaded on the CSV import status screen. I’ve done this about a hundred times and it’s always worked. I see that my PHP version is outdated, but when I choose an updated version, I’m not allowed to “apply” as the instructions say to do.

So I have several questions:

  • Where do I find my error messages?
  • How do I update the PHP version (I just installed this a couple of months ago - why does it need updating?)
  • How can I fix this?

I was able to adjust my config file to see error messages and figured out that my csv needs to be csv-utf8.

However, now the images (which I have uploaded to a subdomain for omeka to grab and then I have the URL on the csv file) are being automatically changed to thumbnails.

This is all new, these same procedures worked a couple of weeks ago.

Looking in the MultiPHP manager in cPanel, it looks to me like your site is running PHP 8.0. So everything should be fine there. If you have further issues with that, send us an email at support@reclaimhosting.com and we can help you troubleshoot further.

Based on some of the suggestions I’m seeing on your post in the Omeka Forum, I’d also make sure the PHP-CLI path is set correctly:

1 Like