Etherpad admin configuration

I installed etherpad (at and it works fine as a user.

However, I am unable to access the /admin site. I set the admin user and password, as seen here:

And I verified the variables in the shell:

root@node597-fncll-etherpad:/# echo $ADMIN_PASSWORD
root@node597-fncll-etherpad:/# echo $ADMIN_USER

But trying to authenticate just results in being asked to authenticate again and again…

1 Like

When you add new variables you have to also restart the Docker server for those environment variables to be used in the install. Otherwise the running instance doesn’t pick up on them automatically.

That being said I tried to reboot it for you and now the whole thing isn’t starting so I may need to dig in further on that installer. Hmmm

Well, it looks like you got it going!

Apparently I just wasn’t being patient enough :slight_smile:

I am having the exact same problem. I have done the things described here and can see via the echo commands that the ADMIN_USER and ADMIN_PASSWORD variables are set. However, I am asked to authenticate again and again.
Any ideas?

Did you reboot the container? That was the fix in this case.

I see you also have a support ticket open regarding this so someone will follow up with you there as well.

Thanks for the response.
I did reboot the container. Just to conform, I did this by going to the dashboard for my environments.
It is still not working.
The help folks responded to my ticket with a link to a video for a desktop installation.
What else can I do?

Based on some investigation, we’ve discovered that ADMIN_USER is not a variable within the Etherpad configuration.

You’ll want to use the username admin and password designated to access the dashboard.