Installing 'inception semantic annotation platform'


It’s been a while since I tried to install something from docker on reclaim cloud; I have an MA student who wants to use ‘Inception Semantic Annotation Platform’ ( ) on a project with folks at a couple of different institutions, so having something on reclaim cloud seems our best option. However… I forget the ins-and-outs of building something from a docker image; and then I think I need to configure things so that the data storage is outside the image, per the info at

Anyway; I’ve tried to build the docker image at the very least, but something’s gone (seemingly) haywire; just the spinning wheel of doom…

So I guess, has anyone tried this particular inception annotator in a cloud instance? Looking for hints, tips, reminders…


UPDATE ok, so i just needed to be patient. Thing installed, runs, yay! But it’s just in it’s ‘demo’ mode. For actually using it, I need to configure the database stuff. Following INCEpTION Administrator Guide I made the config file, and have used apt install to get mardiadb in there. Now the problem is: can't connect to local MySQL server through socket 'run/mysqld/mysqld.sock'.

…further updates as events warrant…

1 Like

ok, while I could get the demo of Inception running, I couldn’t figure out the database stuff. So, looking at some other things I’ve installed, and looking at the documentation, I tried another tact.

  • create docker ce engine container
  • ssh in it; create a docker compose file as per INCEpTION Administrator Guide
  • start the two containers (the db, and inception) with docker-compose -p inception up -d
  • error message in the compose yml about arrays at the depends_on … db… condition_healthy. What the hell, couldn’t figure that out, deleted that entry
  • docker-compose works now; database thingy created, inception created, both running…
  • cannot be found online. it’s supposed to be there at port 8080:8080 so this must be where things have gone sideways. public IPv4 is on for the container and port 8080 is open by default, so…? help?

ps - opening in firefox; no dice. in chrome, I see this error message: ‘ERR_SSL_PROTOCOL_ERROR’


So - i checked the topology of the container. I have access via SLB and Pulibc IPv4 both enable, as well as SSL turned on. I increased the number of cloudlets to 5. And lo! the site turns up at so hurrah!

Hope this helps someone else in the future (probably me).

1 Like

That is awesome, I was going to send you down a bad path of mapping endpoints, but obviously you are in charge here :slight_smile:

ah well it’s entirely possible that something will explode before too much longer. For instance, I have ssl turned on, but when I go to with https, i get an error. With just good ol http, it all works. :man_shrugging:

The shared SSL cert should work if not a region domain, such as, if a mapped domain you may need a load balancer and Let’s Encrypt cert

it is like . I’ve got it turned on, but this error:

Secure Connection Failed

 SSL received a record that exceeded the maximum permissible length.


Will have to look at app details, but wondering if 8080 port is an issue given https runs over port 443, I believe. There may be some reverse proxy weirdness happening, I can find some time tomorrow to explore the GitHub docs and see if I have any insight, which is not a given :slight_smile:

thank you! but i’m just happy that the damned thing seems to be working over http so…

I spoke too soon. Nothing loads today. arrrrgh!

The docker containers are still up, still running, so that’s good, at least. Must be the ports thing.

…ah. Ok, silly me. Forgot the :8080 bit to add at the end. Lord, I hates computers.

in the docker-compose.yml file I used from the documentation, there’s this line:

- "${INCEPTION_PORT:-8080}:8080"

would I change that to :443 ? and presumably I’d have to kill the containers, redo the docker compose command?


Following-up here, sorry for the radio silence. How is this going? To change ports in environments its often the Firewall or Endpoints you want to edit. Have any luck on this?


Um. everything was working fine - until last night. Now everything’s gone. There’s nothing at the dashboard. The site is nuked. This is not good.

This topic was automatically closed after 365 days. New replies are no longer allowed.