Issues with Manual Update to Omeka S 4.0

A faculty member has an Omeka S site that they would like to update to 4.0, in order to use some of the newer features. Since 4.0 is not yet available in Installatron, we have tried a manual update process using the instructions in the Omeka S manual but are getting a 500 internal server error each time: we first tried to update the existing Omeka S site, and then fresh Omeka S installs in case there was some kind of issue with the existing site, and we are getting the same error each time. Does anyone have any suggestions for troubleshooting or for getting this working? Thanks in advance for your thoughts!

Hi there! Often times the Omeka S themes/modules aren’t up to date which can cause issues after the upgrade. I’d definitely recommend taking a look through our guide to Troubleshooting a Failed Omeka S Upgrade.

Hi Meredith, thanks so much for your thoughts! I believe I tried leaving the Omeka S 4.0 modules and themes in at least once on a clean Omeka S install, updating only the config directory, just to see if this would work, and it did not. If I left the Omeka S 4.0 modules and themes in, is there a way they could still be out of date and causing the issue?

An update: I posted about this issue in the Omeka Forums as well, and was told that “sometimes when installing/updating from a zip file on Reclaim, the directory and file permissions get out of whack.” The command line suggestion provided there worked for us in resolving this issue.