Move Omeka files to new installation

I have an Omeka installation that appears to have some kind of corruption. How can I go about making a new clean Omeka installation at the existing domain, and moving the existing files over? Do I just need to make a back-up? Will cloning the site actually create a new installation of Omeka? What’s my best plan? Thanks!

Hi there-- You’re on the right track here but, using the cloning feature will create an exact copy of the site. This will bring over the existing corruption, so that’s no good if you want to get rid of it. What is the URL of the site? We can take a look at it and decide what the best course of action would be here.

Thanks for taking a look:

I ran a malware scan on your site to see if there were any corrupted files on your account. That scan came back clean, so there are no corrupted files on the site. Can you point me to a specific example on the site?

Maybe “corruption” isn’t the right term, but something isn’t working right. My colleagues at the University of Kentucky and I are testing a new theme and plug-ins on this site. We keep encountering an Omeka error, only on this installation, and not on other test sites. The plug-in developer suggested it must be some kind of corruption in the Omeka 2.6.1 installation, which has led us to try to figure out how to migrate the data to a clean install.

I know this is not the Omeka help forum, so I don’t want to get too far into the weeds with this. But here’s the issue: The Simple Splash page plug-in is supposed to search the Omeka items to identify oral history item types and display just those records on a simple page, and it does this by using the admin search function. When I am logged in as admin, Omeka cannot perform this search and generate the Splash page, but it does work when I am logged out of the site. When I am logged in, I get a fatal error message when using the admin search (NOT a item search) for my test oral history items (see attached).

Anyway, none of these issues occur on our other test sites using this theme and plug-ins and also running Omeka 2.6.1.

I see, thanks for the clarification here. Can you submit a ticket to Send along the URL of the site and the screenshot you attached in your previous response. We’ll take a look and follow up with you on the ticket.

Figured I would follow up in this thread with the fix in case someone were to stumble on this. I found a similar error/issue at Catchable fatal error: Argument 2 · Legacy Forums · Omeka and the fix which worked here as well was to reindex the site under Settings > Search (I did have to set the php-cli path first to reindex)