New Omeka S installation, can't login

First time on Reclaim Hosting. I installed a new instance of Omeka S. Everything seemed to have installed correctly, but when I try to login to Omeka, it prompts that the “Email or password is invalid.” I double checked. Also tried the “Forgot Password?” but it doesn’t sent anything to my email. I checked spam folder, but nothing. Deleted the installation and reinstalled, but the same thing happened. Any suggestions for a newbie?

Hey Ted,

Responded to your support ticket but useful info for the forum here too. I’ve seen this in instances where the “Name” field isn’t complete. We’ve been trying to make it a required field in the install but it’s often missed. Can you try reinstalling with “Name” filled out and any other fields for the install. My understanding is they are all required for a user profile to be created.

That was it. Worked like a charm. Fantastic support! Thank you!

Hi Tim,

Worked like a charm. Thanks for the quick response and support.



Awesome, glad to hear it!