Omeka OHMS Viewer error


I have the OHMS Viewer plugin installed in an Omeka instance at, and I’m not able to upload any files within Omeka, or even view a file that was uploaded manually into the cachedfiles folder.

here is my config file:
tmpDir = /home/dpulibr/
players = other,brightcove,kaltura,youtube,soundcloud,vimeo,avalon,aviary
timezone = America/Chicago
exhibit_mode = false
print_mode = false

[DePaul Special Collections and Archives]
css = custom_default.css
footerimg =
footerimgalt =
contactemail =
contactlink =
copyrightholder =
open_graph_description =
open_graph_image =
ga_tracking_id =
ga_host =

and here is the error that displays:

LogicException: OHMS file must be validated before retrieving list of column examples. in /home/dpulibra/
Stack trace:
#0 /home/dpulibra/ OhmsImport_File->getColumnExamples()
#1 /home/dpulibra/ OhmsImport_IndexController->indexAction()
#2 /home/dpulibra/ Zend_Controller_Action->dispatch(‘indexAction’)
#3 /home/dpulibra/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#4 /home/dpulibra/ Zend_Controller_Front->dispatch()
#5 /home/dpulibra/ Zend_Application_Bootstrap_Bootstrap->run()
#6 /home/dpulibra/ Zend_Application->run()
#7 /home/dpulibra/ Omeka_Application->run()
#8 {main}

Can someone help me figure out what’s misconfigured?

I’m running into the same problem. Did you figure it out?

I had missed a step in the instructions that states the xml file has to be zipped to process, so the upload is working. We still can’t get the viewer to play the files correctly, however.

For anyone else having this problem, noting the fixes here:
It’s not mentioned anywhere in the documentation, but you have to explicitly allow the iframe tag in the “Allowed HTML Elements” Security Settings of of the Omeka installation–it’s not allowed by default.

Also, I had an SSL security certificate on my Omeka site, but not on the site that was hosting the OHMS viewer and files. Once they were both secure, things worked fine.

Turns out the problem was that I hadn’t zipped the file. Thank you!

This topic was automatically closed after 365 days. New replies are no longer allowed.