Trouble with OpenLayers in Scripto/Omeka Configuration

So I have installed the Scripto plugin for my Omeka Classic install, and when trying to select “OpenLayers” rather than “Omeka default” in the Scripto configuration settings, I get hit with a “Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in …/plugins/Scripto/ScriptoPlugin.php on line 410” message on the live site.

The thing is there is not an “allow_url_fopen” on that line or anywhere else in that php file.

Has anyone come in contact with this error/know how to fix it?


Hmmm, allow_url_fopen is a default enabled setting on our servers but it’s quite likely that a server slipped through the cracks and it’s disabled for some reason. What domain are you working with, I’d be happy to check on that.

It’s for my omeka install

Gotcha, that setting is a bit more inconsistent on our school setups. Give it a try now and let me know if you continue to experience any issues.

1 Like

Thank you so much, it works!