Installing Adapt Authoring Tool

Going to write out as much as I can in case others run into this problem too.

I’ve been following along the Adapt Authoring Tool guide Installing the Authoring Tool · adaptlearning/adapt_authoring Wiki · GitHub and get to step four before I run into any trouble. I started with Node.js v 10.21.1 LTS (it seems it’s not compatible with newer than v 10.x). I selected MongoDB 4.0.9 (Adapt is compatible with up to v 4.x). I verified that git and grunt were running on my cloudlet as well using the --version command.

In step three the guide says to make sure that MongoDB is running. When I log into MongoDB as an administrator I can see the uptime keeps going up which implied to me that it was running. However when I try step four node install (also tried sudo node install) it takes you through a series of prompts and then times out:

Now we need to configure the master tenant.
Tip: just press ENTER to accept the default value in brackets.

error [03 Jul 20 15:16:57 +00:00] Server selection timed out after 30000 ms
error [03 Jul 20 15:16:57 +00:00] failed to set app.db

I checked out the Adapt forum, and that error seems to stem from MongoDB not being active. So I logged into the command line for MongoDB following their documentation to check the status of and I get:
mongod.service - SYSV: Mongo is a scalable, document-oriented database.
Loaded: loaded (/etc/rc.d/init.d/mongod; bad; vendor preset: disabled)
Active: inactive (dead)
Docs: man:systemd-sysv-generator(8)

I assume that “Active: inactive (dead)” means MongoDB is not running. Following the MongoDB docs, I tried the command sudo systemctl start mongod and get:
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for mongod:

at this point I can’t type anything in the command line, not copy paste of the password, or typing. I’m new to command line but I made it this far. If the community has tips with MongoDB I’m all ears. Thanks!

You hit a similar issue I did with the connection timeout but I haven’t gotten past it. Mongo should start automatically so I doubt it’s not running, more likely some type of firewall or other communication issue between the two containers. For restarting a service in a container like that you’d just restart the container like so:

When I run service mongod status I’m seeing it is open and active

I actually did manage to get an install of Adapt up and running using a Docker method that I’ll document here though and it’s on my list to get this one into a package to make it easier for folks to install on their own.

1 Like

Turns out I didn’t need to go the Docker route. After some more experimenting I think I just had to get the hostname info correct. I spent some time today building out an installer script once I had a good handle on the full installation process and you’ll find that now in the Marketplace under Education (a new category!):

Direct Install Link

I’m going to cheat and use the installer, but my curiousity might get the better of me to try again the previous way. It was a cool venture/introduction to command line, but I am so so grateful that you built the installer. Mind-blown.
Thanks Tim!

Hi there,
I am currently teaching an eLearning module and I have asked my students to install the Adapt authoring tool. Most have managed to install it by following the github wiki instructions. You mentioned you have created an installer script with a direct link to access. Is this publicly available or available to members on here? If so, it would be really useful to be able to provide the details to some of my students that are struggling with the install. I’m keen to have them up and running, as quickly as possible, and I don’t want to put them off at the first hurdle! I have a mix of Mac and PC users. Thanks for your time!

Hi there, the installer we built uses our cloud platform. You’ll find instructions on getting it up and running at Adapt Authoring Tool now in Marketplace. Note that this is running on a hosting platform with costs associated with doing that rather than locally on a computer.

Hi, Getting an error when I try to sign in; Reclaim Cloud signups are currently being limited to educational institutions. You must provide a .edu email address to proceed
Our college does not have .edu email addresses - I am based in Ireland; my email address ends in .ie
Is there a way around this?

If you can give us an example of the type of email ending your college provides we can look to add the extension (.ie by itself is too broad) but yes, our cloud platform is exclusive to educational customers at the moment.

I’ve just updated my profile with my college email address. Is it possible to send you a private message with my address or can your admin team access it from my profile?

I’m able to access it. Give the signup a try now and it should work. Let me know if not.

Hi Tim,

Just tried now but it didn’t accept my credentials

Sorry, every so often I’m reminded I suck a bit at programming. Errant period in our code :slight_smile: I just tested with your email and it was successful now (which also means others at your same university will be able to signup for an account).

:slight_smile: Ok, It accepted my email but I’m still waiting on the activation link.

It may get caught in spam filters, that’s something you’ll need to address with your institution as we don’t have any control over that aspect of the service. Sorry I can’t be of more help.

Yes, found it in my junk mail. Thank you so much for your assistance!