Running sudo commands from cPanel's built-in Terminal

Hello! Hopefully this question isn’t redundant – I tried a few search terms and wasn’t able to find something that seemed to quite answer the question. How can I use sudo commands from the built-in Terminal in cPanel? Whenever I try, it says I am not a sudoer.

Thanks in advance for any help!

Hi there,

I do see that you submitted a ticket shortly after posting this, but this is a common question we get and it will be good to have this publicly available. Apologies for resurrecting an old thread!

sudo is a UNIX/Linux command that allows a user to run commands as the super user, root, or other restricted users. For security reasons, standard user accounts on servers are not given the ability to use the sudo command. If sudo is a necessity to run or install something in a shared hosting environment, chances are you will not be able to install it. However, our new cloud platform, Reclaim Cloud, offers isolated environments where you can spin up all sorts of applications with root access for yourself and no threat of impacting anyone else’s environments!

1 Like

I also have problem with commands put and call. are they the same as sudo?

thank you

I’m sorry, but I’m not familiar with the put or call in the context of a typical linux shell. What is it you are hoping to do?

Thank you @taylorjadin

I was trying to show someone with put and call to upload files to public_html; but the terminal shows me that the “command not found”.

So I am not sure why we can not use put and call in the reclaim hosting

If you are referring to the sftp command put, you will need to connect using the interactive client like this:


Then you can use put to send a file:

I’m still not familiar with the call command though, sorry.

thank you very much @taylorjadin !!