WP adding domain name to hyperlinks

I may not be quite so new as I once was, but I’m still very much early in the learning curve.

I have a number of hyperlinks, particularly linking out images to external webpages. These links are set in the WP Media library. When I click on the image from the homepage, WP is inserting my domain name (arhenle.com) in front of the hyperlink. This doesn’t happen when I click on the same image from a secondary page.

Is there something I’m missing that I need to do to turn off inserting the domain from the subsidiary page? I’d like the images to lead to the same place regardless of which webpage they’re on.

Any assistance welcome with gratitude.

Hi Alea,
When you’re linking to the external locations, are you linking on the post in particular or for the image directly? I would recommend setting a custom URL whenever you’re embedding an image in a post, otherwise, the behavior you’re seeing is expected. The Image will first show up on your site then you can click through to the custom URL you set.

I hope this provides some additional clarification! Let me know if you have any other questions.

Thanks for the comment. I went back and re-did the links, and that may have cleared something out. Things are working now (fingers crossed).

1 Like

This topic was automatically closed after 365 days. New replies are no longer allowed.